System & Software Requirements for mycourselink

You can visit our System Check page to quickly find out if your system meets the minimum requirements. Please note, these requirements are for accessing the learning management system and its tools. The format of content files will vary from course to course and may require additional plug-ins, applications, etc. to be accessed. It is your responsibility to ensure you have the appropriate technologies to access the course materials.

Browser support

D2L Brightspace is committed to performing key application testing when new browser versions are released. However, due to the frequency of some browser releases, D2L cannot guarantee that each browser version will perform as expected. If you encounter any issues with any browser versions, contact us at mycourselink@lakeheadu.ca, and we'll determine the best course of action for resolution.

D2L Brightspace provides a list of supported browsers in the Platform Requirements.

Note the following:

    • Ensure that your browser has JavaScript and Cookies enabled.
    • For desktop systems, you must have Adobe Flash Player 10.1 or greater.

 

 

 

 

.